首页 > 程序 > ubuntu1310安装wps支持

作者:ghostry 发布时间:2013-10-29 浏览: 13143

转载注明出处: https://blog.ghostry.cn/program/ubuntu1310-an-zhuang-wps-zhi-chi.html

ubuntu1310启用了多架构Multiarch,原来的软件包ia32-libs消失了。

sudo apt-get install ia32-libs  
正在读取软件包列表... 完成  
正在分析软件包的依赖关系树         
正在读取状态信息... 完成         
现在没有可用的软件包 ia32-libs,但是它被其它的软件包引用了。  
这可能意味着这个缺失的软件包可能已被废弃,  
或者只能在其他发布源中找到  
可是下列软件包取代了它:  
  lib32z1 lib32ncurses5 lib32bz2-1.0  
  
E: 软件包 ia32-libs 没有可供安装的候选者 

使用wps的话。得用32位库支持啊。经过多方查找和实践,最后发现如下方式解决问题

sudo apt-get install libc6:i386 libstdc++6:i386 libfreetype6:i386 libglu1-mesa:i386 libcups2:i386 libglib2.0-0:i386 libpng12-0:i386 libsm6:i386 libxrender1:i386 libfontconfig1:i386



标签: ubuntu wps

上一篇: 百度网盘+aria2神器,欧耶~抛弃迅雷离线
下一篇: ubuntu安装opengl支持[转载]

已有 13 条评论 »

  1. 提示已经说清楚了有下列软件包取代了他,sudo apt-get install lib32z1就搞定了。

    不用那么麻烦1

    1. 原来如此,受教了.

  2. 啊,能用wps了啊,如果能用autocad2012我就转战Ubuntu

    1. autocad我记得有。2012就不知道了。

  3. 又,刚发现评论的时候,看起来你的防止垃圾评论的方法是,提交前给评论内容加个前缀,然后后台检查这个前缀。。。
    个人觉得ajax方法比较好。
    有人开发了几个文件,替换掉原来的评论方法,然后就可以直接删掉wp-comments-post.php就可以了
    有兴趣我可以e-mail个你个
    你也可以很容易在网上找到的。

    1. 这方法不错啊,话说我也可以考虑这么弄了,总比我在那过滤关键字强多了

    2. 谢谢啦。发我看看呗。

      1. 要包不留邮箱,小心菊花万人捅
        自行下载留存档,过几天我说不定就删了。
        http://doc.argcv.com/pkg/comments-ajax.zip

        解压后得到两个文件 comments-ajax.js和comments-ajax.php,丢主题包去
        然后

        修改主题的header文件,添加include 那个js文件(comments-ajax)如果没有jquery , 添加 jquery。

        完毕

        1. 你没有收到我的邮箱通知么?你这个是wp的。。我博客是typecho。。。

          1. 没有。。。连spam中都没有

  4. 刚发现下面这么一行字
    欢迎评论!歡迎評論!Comments welcome!komentoj bonvenaj!댓글 오신 것을 환영합니다!

    真是各种语言思密达

  5. 看起来好麻烦的样子。我用的是fedora

    yum localinstall wps.rpm

    自动解析依赖关系,然后从 fedora的repo或者 rpmfusion找到就完了
    转投我大fedora阵营吧

    1. rpm系列不会有这问题啦。deb的才有。

添加新评论 »

*
*

欢迎评论!歡迎評論!Comments welcome!komentoj bonvenaj!댓글 오신 것을 환영합니다!
:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: :cold: :cryy: :cute: :shy: :sleep: :struggle: :tea: :yahou: